Go Back   Ford Expedition Forum > Ford Expedition Forum > General Discussion

Sponsored Ads
Register to remove these ads.


General Discussion

Worst year(s) expy made


This is a discussion on Worst year(s) expy made within the General Discussion forums, part of the Ford Expedition Forum category!
seems the 97-02 5.4's had the throttle sticking problems my wife bought an 02 EB 5.4 in feb, and the ...



Reply
 
LinkBack Thread Tools Display Modes
Old 06-09-2011, 03:49 PM   #11 (permalink)
 
onyxxtreme's Avatar
Registered User

 
Join Date: Feb 2011
Location: afghanistan
Posts: 4
Default

seems the 97-02 5.4's had the throttle sticking problems
my wife bought an 02 EB 5.4 in feb, and the second day she had it, the throttle stuck. She was going about 50mph, and couldnt pop it in neutral, so she destroyed teh front brakes getting it stopped. I was in afghanistan when it happened so i dont know the "real" story of what happened. But with all the TSBs on that problem, seems Ford could have done something about it, considering what toyota had to go thru.
The truck is currently in transit to here in germany, and once it gets here I'll be able to check out the TB to see if that was infact the problem.
onyxxtreme is offline   Reply With Quote
Old 06-10-2011, 12:40 PM   #12 (permalink)
 
smo0othride's Avatar
Full Access Members

 
Join Date: May 2003
Location: San Diego, CA
Posts: 827
Default

Originally Posted by onyxxtreme View Post
seems the 97-02 5.4's had the throttle sticking problems
my wife bought an 02 EB 5.4 in feb, and the second day she had it, the throttle stuck. She was going about 50mph, and couldnt pop it in neutral, so she destroyed teh front brakes getting it stopped. I was in afghanistan when it happened so i dont know the "real" story of what happened. But with all the TSBs on that problem, seems Ford could have done something about it, considering what toyota had to go thru.
The truck is currently in transit to here in germany, and once it gets here I'll be able to check out the TB to see if that was infact the problem.
The engine turns off even while in drive, I just tried it this morning.
__________________
2003 Expedition 5.4L XLT

Upgrades:
Hellwig Front Anti Sway Bar / Belltech Rear Anti Sway Bar
Bilstein Heavy Duty Shocks || Truxxx 3"/2" Body Lift || 285/60/18 Nitto A/T's
93 Octane Custom Tune by Matt(Green03)
Hawk Ceramic Brake Pads ||PowerStop Drilled Rotors
Gotts w/ K&N Intake
5% Limo Tint
Fusion Painted Grill and Cladding
Hertz Door Speakers w/ Dynamat
7" in dash screen for DVDs/GPS/Backup Cam
smo0othride is offline   Reply With Quote
Reply

Bookmarks




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Dodge Ram Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Scion FR-S Forum
Softball Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum