Go Back   Ford Expedition Forum > Ford Expedition Forum > Transmission & Drive train

Sponsored Ads
Register to remove these ads.


Transmission & Drive train

AWD/4WD Selector switch question


This is a discussion on AWD/4WD Selector switch question within the Transmission & Drive train forums, part of the Ford Expedition Forum category!
Register to remove these ads. It's free! Hi, We purchased this 1998 Expedition with the 4.6 in late March 2005 ...



Reply
 
LinkBack Thread Tools Display Modes
Old 09-01-2005, 01:09 PM   #1 (permalink)
Registered User

 
Join Date: Mar 2005
Posts: 12
Default AWD/4WD Selector switch question


Register to remove these ads. It's free!
Hi, We purchased this 1998 Expedition with the 4.6 in late March 2005 with 138k miles. There have been no problems until last week when I switched from 2WD to AWD and then to 4WH and then to 4WL. It went into AWD but not into 4WH or 4WL. I took it to our mechanic of 15 years and he had one of his employees replace the two speed sensors. However, now the AWD light on the dash stays lit solid where it used to flash. When switching from AWD to 4WH, nothing happens and the AWD light on the dash stays lit. When switching from 4WH to 4WL, nothing happens and the AWD light stays lit. When switched back to 2WD, the AWD light goes out.

I also had him drain and refill the transfer case with fresh oil since replacing the speed sensors would cause a small amount of fluid to be drained. The questions I have are:

1) Should the AWD dash light flash or be solid? My mechanic left yesterday to go hunting for a week and the guy now in charge says he called today a local Ford dealership and was told the AWD light should be solid, and if it was flashing before then there was a problem before. If that is the case, then at least the speed sensors fixed that unknown problem because now the AWD light is solid. So, flashing or solid AWD light...which is correct?

2) Why would the AWD light stay lit and the 4WH and 4WL lights not come on when the switch is turned to the appropriate spot, and why would the 4W not engage with two new speed sensors?

3) Why would there be a whine when driving now if the fluid was drained and supposedly refilled? The whine is not engine noise as it does not do it when revved in Park or Neutral, and it did nto do it until the speed sensors and fluid were changed.

Thanks.

Andrew
amkazen is offline   Reply With Quote
Old 09-13-2005, 12:40 PM   #2 (permalink)
Full Access Members

 
Join Date: Sep 2005
Posts: 60
Default

Andrew

The light shouldn't flash. WHen its flashing, there is an issue in need of repair/fixing. Anytime you catch a flashing light on the dash, or 99% of the time their is a problem that needs remedying.
(thats why alot of the time nowadays they are referred to as dummy lights)

When you move the selector switch, are you in P or N or D?

Put it in N and then turn the switch. You should hear several relays clicking that engauges the x-fer case.

With 138K miles I hope you gave it a good once over before you bought it. Depending on how the previous owner/owners treated could be why you now have a whine. If that x-fer case wasn't serviced like it was supposed to be at 60K and 120K
(I believe its every 60K) Then you could have had a bunch of crappy buildup in there that was thick and kept it from whining. Replacing it with nice clean dex could make it whine. Usually though, a ford whine is a rear end. Check the GL-5 level in the rear, and if you have it replaced, make sure you use synthetic GL-5 fluid.

Crawl up underneath it and check to see if any plugs aren't plugged in as to why you get no lights. It could also be burnt out 4wd indicator lights.

Also, does the amount of "whine" increase with speed?
stang99x is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Dodge Ram Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Scion FR-S Forum
Softball Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum